About Us

Browsing Requirements

To get the most out of the Pacific Pride site, updating your web browser to the latest version will ensure a full experience.

Browsers and Security

If you do not have the most up-to-date version of your current browser, choose your browser of choice from the right column, visit the vendor's website and download the most current browser version. This ensures your security measures are up-to-date, as well as experiencing all the features available on the Pacific Pride website.

For best results we recommend Google Chrome or Mozilla Firefox. Internet Explorer users will have the lowest level of performance and depending upon your hardware and operating system, some features may not work with Internet Explorer.

Software Requirements

Document downloads are available in multiple document formats. You can download Adobe Acrobat Reader and other software to view these documents. Choose the software that is best compatible with your operating system.

Site Issues

Having problems viewing the site or receiving an error message? Send an email to cservice@pacpride.com to let us know about the issue, and we will work to resolve it ASAP.


Helpful downloads to improve your browsing experience:

Viewing downloaded files: